Announcement

Collapse
No announcement yet.

Infection from hydro?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • blueskies
    replied
    Thanks for all of the replies. My Dr.'s office called yesterday and said that I definately did not have an infection. I had such painful burning and increased frequency for about six days, I was sure I did. Thankfully, my symptoms have impropved. I did take three days of antibiotics that they gave me when I went in to give a urine sample. I guess it is just going to take some time for my bladder to heal from the hydro.

    Leave a comment:


  • vm
    replied
    Yup, I got an infection after my hydro and my uro had even put me on antibiotics for 3 days after to prevent infection. I ended up going in for a culture a couple of weeks after, maybe, and sure enough - infection.

    Leave a comment:


  • seamus
    replied
    Hi,

    I just had a hydro 2/17 and am still in pain even thought the hydro was good news. Go figure?!?!?!?

    Leave a comment:


  • dixiefireball
    replied
    i hate to say it but i felt worse after my hydo and i did end up with an infection i cant really say if for sure it was from the hydo but shortly after i had it i had an infection i hope you feel better soon sending you prayers. grouphug

    Leave a comment:


  • DanaW
    replied
    I had more pain following my Hydo. than before. That was back in Sept. 03 I dont' think it is unusual to have more pain or some pain following that procedure. For up to a month or so. Hope it gets better! Hang in there

    Leave a comment:


  • khouse
    replied
    Brat,
    My Mom has IC also, I didn't realize your Mom had IC, and they say it is not hereditary!
    Love,
    Kim

    Leave a comment:


  • tigger_gal
    replied
    I had mine on the 4th and i had an iv drip on anti's amd was given 3 days of levaquin to take after...
    I to was in pain (still am) and just was tested friday no infection.. My mom has ic too so I called good old mom and she said what I am and you too I see is normal that it can take 3 to 4 weeks to see improvement.. still waitnig but i do void a whole ounce more then what i did yippie )
    hoping you feel better soon
    Brat

    Leave a comment:


  • blueskies
    started a topic Infection from hydro?

    Infection from hydro?

    I had a hydro on Feb. 14th. I was doing ok but four days ago I started having burning and increased frequency. I'm much worse than before the hydro, now I'm really frustrated that I had it. I went in to the Dr.'s today and gave a urine sample. They do not think I have an infection but put me on three days of antibiotics until they get the results back.

    Has anyone else gotten an infection after a hydro? The Dr. did have me on IV antibiotics during the procedure. Has anyone felt ok then a week later felt much worse?

    Thanks.
Working...
X