Announcement

Collapse
No announcement yet.

possible UTI

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • charmedx3
    replied
    no uti

    So I called drs office 1st report is normal but they are doing a culture. just my luck

    Leave a comment:


  • charmedx3
    replied
    ok i am back now. met my husband for lunch after the trip to the lab. i can call them at about 2 and they will see if my results are back. if they are ready then i will have my drs office call for results.

    Leave a comment:


  • charmedx3
    replied
    Thanks amy!
    I had a really bad night. I am experiencing some retention. last night my bladder felt full but only a trickle came out. I was up about 4 or 5 times last night. I know I should do this but to pee i had to lean over on the toilet. I went to my PT appt today and I was able to pee 2 times during treatment! yeah! So I called my dr I am going to run over to lab & do a urine test. They are requesting a dip & culture. My pain this weekend was a 7 and still as high today. I really hate this stupid IC!!!!
    I just want to be normal again!! Now i am crying! So off I go to do my stupid test!!!!!!!

    Leave a comment:


  • ihurttoo
    replied
    I agree that since the specimen was contaminated, you are definately better off to go ahead and drop off another urine sample and find out for sure. Even if the urine strips dont show anything, you still cant be sure it isnt an infection. I have had several UTIs that the dipsticks missed, and they only showed up when the urine was cultured. And if the test strips DO pick it up, then you are going to have go get on abx anyway. So, either way, you are going to have to drop off another culture, so you may as well go ahead and do it.

    I hate that you have been suffering all this time. I just hope that it turns out to be an infection instead of a flare, that way at least then you will hopefully feel better when you start on abx.

    Sending hugs and hope you feel better soon!
    Amy

    Leave a comment:


  • stacey79
    replied
    I have lots of trouble with UTIs. I tend to have other symptoms that I don't have for a flare - low-grade fever, extra tired, extra weepy, etc. A warning for those at-home test strips. If you read the package, most recommend that you have the urine in your bladder for at least two hours (I think) or overnight. That gets awfully difficult when you're not feeling well.

    If you think it could be an infection, you really are probably better off going back to your doctor to have it checked again. Even if you do test positive at home, your doctor will probably want to re-test it anyway.

    No matter what, I hope you're feeling some relief soon.

    Leave a comment:


  • humpieumpumkin
    replied
    Roxie
    My old uro swore that Cipro had antiinflamatory properties and always insisted I finished them even if the test came back neg...I was bad and never did...they yeast would throw me into a killer flare. I don't know, I guess it was the lesser of two evils. If I truly have an infection, I need to go levaquin or the like. My uti are growing resistant I think

    Erika

    Leave a comment:


  • charmedx3
    replied
    well i don't know what to do. I did the AZo test strip last night and both patches had small purple. I think i will go buy more strips and do 1 more if it is the same I will go in for another test with dr. I am really in alot of pain this weekend. I haven't had a UTi since I was pregnant in 1999. I have had 2 in my life 1988. 1999. I should say 2 documented infections. thanks

    Leave a comment:


  • Roxie2007
    replied
    HI! My Urosurgeon/IC specialist puts me on Cipro 500mg for 3 days.....even if the test comes back negative. This always works for me......maybe it would work for you also? Roxie

    Leave a comment:


  • GriffsMommy
    replied
    Sorry that it's not an infection Charmed. How crazy life is for all of us when we're upset that we DON'T have an infection! I know exactly how you feel though, I have had some killer flares and thought this has to be an infection, went in for a culture and nothing! It drives me crazy but honestly I don't even want them to culture my urine anymore because I have a PPO with a really high ded so I get a bill for $28 to pay everytime they culture it! If I did a culture everytime I was flaring I would go broke! I hope you feel better soon, I wish it was just an infection that they had never caught before but we know that this is just life with IC

    Leave a comment:


  • charmedx3
    replied
    well my culture came back contaiminated so the nurse practioner left it up to me as to whether I wanted to do another test. I said no. The chances that I have a uti are so slim. I am in a lot of pain right now if it isn't better by next week I will do another test.
    My neighbor just bought the test strips---she has a uti according to the strip so I might get one from her and see what it says.

    Leave a comment:


  • charmedx3
    started a topic possible UTI

    possible UTI

    I went in saw my dr today. (gp) She did the standard urine test. Asks if I had blood in urine before: always. Wants to send out for culture-- It is probably negetive but we shall see. I am hoping it is a infection but I doubt it. I should say that white cell count was fine so the blood is the only thing going on.
    I will find out the end of this week. Sometimes I just wish it is a missed infection for the past 5 yrs bt I know it isn't. It would be so nice if it was just solved just like that.
Working...
X